HomeNewsAMD Confirms USB Problems with 500-Series Motherboards

AMD Confirms USB Problems with 500-Series Motherboards

Following the launch of the AMD 500-series motherboards, there has been something of a relatively quiet but consistent complaint from a number of users. Namely, for reasons unclear, some USB devices utilizing the platform would randomly disconnect. Something that would clearly represent a very vexatious problem.

Well, it may have taken a while (and some would even argue that it’s existed since the launch of the AM4 platform), but following an official post on Reddit, AMD has (finally) confirmed that there does seem to be a problem with their 500-series motherboards and certain USB devices.

AMD Admits 500-Series Motherboard USB Issue

Firstly, we should note that this does not (yet) appear to be an issue with any particular AIB partner. So, MSI, Gigabyte, Biostar, etc. it doesn’t matter. Who actually supplied the motherboard is seemingly not the problem. This is possibly (if not likely) something to do with the ‘AMD’ aspect of the technology.

So, what exactly is causing the problem? Well, in a nutshell, nobody (not even AMD) seems to quite know for sure yet. It is, however, being cited on several occasions that the problem does seem to present itself most notably when a VR headset is used. As such, if you too are having similar issues with your 500-series motherboard and seemingly random USB disconnections, AMD wants your help!

How Can I Help?

AMD is actively asking users experiencing the problem to post a direct reply in the Reddit posts comments stating their system specification and any other relevant details. For example, which device seems to have the disconnection problem and what else was plugged in at the time. With this, they may choose to get back in touch with you for further clarification, but all going well, a collation of this consumer information will help them, hopefully, find out what’s going wrong (and fingers crossed, fix it!).

“AMD is aware of reports that a small number of users are experiencing intermittent USB connectivity issues reported on 500 Series chipsets. We have been analyzing the root cause and at this time, we would like to request the community’s assistance with a small selection of additional hardware configurations. Over the next few days, some r/Amd users may be contacted directly by an AMD representative (u/AMDOfficial) via Reddit’s PM system with a request for more information.

This request may include detailed hardware configurations, steps to reproduce the issue, specific logs, and other system information pertinent to verifying our development efforts. We will provide an update when we have more details to share. Customers facing issues are always encouraged to raise an Online Service Request with AMD customer support; this enables us to find correlations and compare notes across support claims.”

If you do, therefore, want to learn more or perhaps submit your own experience of USB disconnections (specifically for 500-series motherboards it should be noted), you can check out that Reddit post via the link here!

Leave a Reply

- Advertisment -

Most Popular

Recent Comments

%d bloggers like this: